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Supplementary to IRONCAD Getting Started Guide on creating drawing or drafting sheets from 
part/s from a working scene, title blocks and adding BOM column feature. What will be shown 
are step by step screen shots similar to what will be seen as you follow this supplementary 
guide.
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For this supplementary guide, the model used is the I-beam.ics from C:\Program Files>IronCAD>2015>Tutorials>en-
us>I-beam.ics. This documentation will highlight some items from the ICGSG on the Standard Views Creation and the 
use of Select Par/Assembly to Project feature. Also, it will show the options available on adding columns on the default 
Bill of Materials. It will also present how it will done in CAXA Draft. Doing sections and annotations have been covered 
by the ICGSG and will not be shown here.

To begin with open the en-us folder to access the I-beam.ics

file:///C:/Program
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Click OK on the prompt screen and on the next screen select as what is shown and again click OK.
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Select Save As and set it to your selected working directory.
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This as an example on my system.
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Go to File>Properties to fill the necessary details.
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On the IronCAD tab of Document Properties, fill the title, the author and click Apply. On the IronCAD 
Custom, select the list on the drop down list on name and fill the value. Click Apply and OK.
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Go to File>New>Drawing. On the New Drawing dialog screen, select the ISO tab and select A3tam template, third 
angle metric templates available from this link http://www.ironcad.com/support/community/i...showtopic=10056.
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On the Properties pane, LMB click Standard View icon from the Actions selection. 

On the Standard View Creation dialog, tick Select Part/Assembly To Project option. As it opens a scene list, LMB 
select I-Beam and click Apply. Check and confirm the Current Front View Direction and select the Views to show.
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Go to File>Save As to your working directory. Saved it with a file name I-beam_myproject.icd
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On the Companyname text, you may edit through Properties and replace the entry or delete the Text and replace 
it with your company logo bitmap image by going to the IC menu button>Create>Object>Insert Object>Create 
from File>File Folder>Save. Re-size the bitmap to fit and put in place box where the Companyname used to be. 
You may Save As again as customize A3tamcompany template.icd (shown on the next slide) on the Program 
Files>IronCAD>2015>AppData>>en-us>Template>Drawing>ISO folder and close the drawing. Open the file 
name I-beam_myproject.icd to continue. 
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RMB click Title on the Tile Block to select Properties. On the Page Text Style Properties dialog, select Link to property 
from as shown. On the Property Name drop down list, select IC-Title and click Apply > OK.
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RMB click on the Drawing View, on the View Properties dialog, Display shows Geometry and Frame features to tick 
select. Tick Name to display on Drawing View. Repeat the step for each Drawing View required on the sheet. 
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Create a Part Name field on the Title Block as shown
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At the Actions from the Properties Pane, LMB select  New Sheet. From New Sheet dialog on the ISO tab, select your 
customize template. As for this guide, A3tamSD is used.
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On the Standard View Creation dialog, tick Select Part/Assembly To Project option. As it opens a scene list, LMB 
select Top Plate and click Apply. Check and confirm the Current Front View Direction and select the Views to 
show.
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Create a Part Name field on the Title Block as shown
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Create a New Sheet and on the Standard View Creation, select Bottom Plate to create Drawing Views selected.
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Create a Part Name field on the Title Block as shown
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Create a New Sheet and on the Standard View Creation, select Guide Pin. Orient Current Front View Direction and 
to create Drawing Views selected.
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Create a Part Name field on the Title Block as shown
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LMB click on Sheet1 tab, and from the Annotation tab, LMB click on Bill of Materials
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On the Create Bill of Materials or Template dialog, LMB select Default BOM 
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On the generated BOM on the Sheet1, RMB click and select edit to add a new column. 
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On the Bill of Materials dialog, RMB click the header on the D column. Drag column E to the left to retain the 
column position.
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On the Bill of Materials dialog, LMB double click the E column to open the BOM Column Header dialog. From the 
Column title drop down list, select Material and click OK.
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The BOM displays updated column field. Follow the previous step to show more required information to display 
on the BOM
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CAXA Draft or IRONCAD Draft works differently from IRONCAD Drawing if based your experience as a 
IRONCAD Drawing user. The basic conventions and templates are also different but drafting tools available for 
CAXA Draft is more robust for detailing work as it picks up more line details projected from the 3D model 
created.

I like to thank the guidance from IRONCAD SUPPORT / USER COMMUNITY members: Kevin DeVoll, Darius 
Leczynski, Jonas Bryntesson, Malcolm Crowe and others for their insight on guiding users to work with CAXA 
Draft.

The methodology used for this CAXA Draft section of this guide is to migrate a basic IRONCAD Drawing user 
familiarity. Setting up CAXA Draft to display features previously done with IRONCAD Drawing. The CAXA Draft 
features: a set of Draft templates different from Drawing templates; frames, BOM behavior, association are set 
differently.
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IRONCAD.CAXA Draft new drawing always opens on a Model Space mode as a sheet tab indicates Model. By 
default it is set to create a 2D model or drawing as drafting feature of CAXA Draft, and project the 2D models to 
Viewport/s on the Layout Space as a convention of 2D CAD program. Layout Space is an insertion created by 
RMB click on the Model tab.

Layout Space is also used to project your 3D views using the features (e.g. Standard View from the Generate 
View group to display the 2D views of the created 3D model from IRONCAD's 3D Scene) and tools from the 3D 
Interface tab.
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CAXA Draft does not have sheet templates similar to IC Drawing stored on the template library. It must be 
noted that sheet frames and title blocks are independent entities associated with a drawing template, with 
each having a distinct file:

● drawing frame file format *.cfm (CAXA Frame)
● title block file format.chd (CAXA Header)
● Drawing template *.tpl (Template)

Combination of CFM and CHD all settings for dimensioning, Bill of Materials, title block, part sheet, etc. 
together form the TPL file.

Templates can be stored in two different places.
Program folder:
C:\Program Files\IronCAD\201x\bin\CAXADraft\Template\en-US
User folder:
C:\Users\*USER*\AppData\Local\CAXA\CAXA DRAFT MECHANICAL CXIC-INT20xx\xx.xx\en-US\Template

TPL files saved under the Program folder will be shown as system-defined templates.
TPL files saved in specified folder will be shown as user-defined templates.

It is basically no difference between these files. They are saved, however, on these various points depending 
on some of the commands in the program. The templates in the two folders will be shown separately in the 
system. 
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To set a similarity and keeping it 
simple, using the A4.icd to be 
exported as a .dwg to be used 
and set as a A4 drawing frame 
for template for CAXA Draft. 
Save it to working directory that 
you are working with IRONCAD. 
Box select the existing title 
block and delete.
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If there are unnecessary objects that cannot be deleted, 
they may be grouped as an object. Disassemble 
everything, selecting all and explode the drawing frame 
(write explode [Enter] or click the Explode button from 
Modify icon group of the Common tab)
 
Or go to the Dimension tab for the Style Manager and 
unlock entities that needs to be selected and deleted.

Go to Paper Settings in the Paper tab.
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Check the current settings: Paper Size is set to A4, paper
orientation at Portrait and Import Frame is set to <None>.
LMB click OK or press Enter.

LMB click Define Frame button to select
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Box select all lines and possible 
frame-text that completes the 
frame information, otherwise draw 
lines, boxes and place additional 
text information to complete before 
selection
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RMB click the orange boxed crosshair cursor 
at the snap at the bottom right hand corner of 
the frame after selection to define the base 
point which controls the frame placement. 

LMB click the green boxed crosshair cursor at 
the  Positon marker as defined.
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The Select Paper Size of Fame 
window prompt is displayed after the 
corner click. LMB click the Using 
Custom button to save your 
customize frame other than that have 
the system-based (A4, A3, A2, etc)
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Name the file. You may do the same 
process outlined for other frame 
formats

The file type *.cfm (CAXA Frame) and 
ports as standard in the personal 
CAXA folder:

C:\Users\ * USER * 
\AppData\Local\CAXA\CAXA
DRAFT MECHANICAL CXIC-INT20xx
\xx.xx \en-US\Template

Or
Program folder:
C: \Program Files\IronCAD\ 20xx\bin\
CAXADraft\
Template\en-US

Or
D:\IRONCAD 2015\DWG_template 
As shown on the new page

file:///D:/IRONCAD
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File can then be moved to the User or Program
Files folder, if you rather store all the templates
there.
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Create drawing titleblock CHD (lines and text
Which is usually located in the right-hand bottom
of the Drawing). Open A4.dwg. Delete everything
Except the drawing title block. Select all lines and
all text.

Create drawing titleblock CHD 
(lines and text which is usually 
located in the right-hand bottom
of the Drawing). Open 
A3(EN).template. Select all lines, 
all text and delete everything 
except the drawing title block. 
This title block has a first angle 
symbol and we have to edit 
symbol so the title block will be 
specified for third angle 
drawings.
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Create drawing titleblock CHD (lines and text
Which is usually located in the right-hand bottom
of the Drawing). Open A4.dwg. Delete everything
Except the drawing title block. Select all lines and
all text.

Scroll to zoom in at the 
title block. LMB click 
select the existing frame 
and delete.
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LMB click the Explode icon and box 
select the title block.
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Create drawing titleblock CHD (lines and text
Which is usually located in the right-hand bottom
of the Drawing). Open A4.dwg. Delete everything
Except the drawing title block. Select all lines and
all text.

LMB click select all the lines and circles on the 
first angle drawing, RMB click to move in an 
area to rearrange to display as the third angle 
projection symbol. RMB click and move back to 
position



  

IRONCAD SUPPLEMENTAL DRAWING & DRAFT 101

With the paper frame shown, LMB click the Define Title Block button to box select the title block and mark the 
position. LMB click the Save Title Block button to save customized third angle title block.
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Disassemble the title block by exploding it (write
explode [Enter] or click Explode button in the
Modify icon group from the Common tab).

Importing drawing titleblock CHD (lines and text
which is usually located in the right-hand bottom
of the Drawing). Open A4.dwg. Delete 
everything except the drawing title block. Select 
all lines and all text. Make sure that there are 
text boxes at each title heading and that text 
size for these is correct, it can be easily 
changed via Property Browser for Iindividual 
selected text boxes.
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If necessary, remove the text boxes 
that are available for each property, if 
they are not already defined as system 
attribute, then these are created at a 
later stage.

The difference between plain text and a 
system attribute is that plain text is 
adjusted with the usual text tool that 
appears when you double-click a text
box.
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Just to view a standard CAXA Draft title block from a native CAXA template to illustrate the
customization that can be done in CAXA.
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Sometimes it practical to delete all text box from the title block and specify anew if it seems not work with a 
imported title block.

LMB click Edit Title Block button and again LMB click Attribute definition button to open the Attribute definition 
window. Fill the name and description fields under Properties and tick Assign two points at Location Mode as it 
allow easier placement on the title block places. 
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You may also select the Text Style from the Text Setting.
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After setting Attribute Definition on the title 
block,LMB click Quit Block Edition button to 
close. LMB click Save Title Block button and 
save as ICDTB.chd.

Create a layout by RMB click the Model tab.
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Go to Paper Settings and set paper size, scale, 
orientation and import frame type. LMB click OK

LMB click Import Title Block button and select 
the custom title block file.
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Creating a customize template. Go to 
File>CaxaDraft>New>Draft 
TEmplate>ISO>Blank>OK

Go to Paper Settings: set paper size 
and the customize A4ICD frame from 
the Import Frame list and click OK
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Import the title block file you have created to complete your customize sheet.
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Save as a customize template on the stored folder on the path as a .tpl file.
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BOM and Part Sheet in the 
template (.tpl)

Open a new CAXA Draft 
and select the template 
A4ICD or the customized 
template you have created.
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Go through all settings by LMB click 
the Style Manager button on 
Options of the Tool tab.

This allows to check and set the 
settings for  layers, line types, 
dimensioning styles, welds.etc.,
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Go to the Paper 
Settings and set the 
Bom to IC BOM on 
the Current style 
feature. Change the 
Paper Scale to 1:2.
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LMB click the Standard 
View button from the 3D 
Interface tab. Browse the 
directory to select the 3D 
model scene file. Only 
display the Isometric 
View and click OK.
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Position the placement of isometric drawing and LMB click select the Update 3D Bom button to 
set the BOM.
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Tick the Fill Bom box and LMB click OK. It opens the Fill in Bom(ISO) to view the BOM detail setting 
features, LMB click OK to exit.
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